Dewd Dropdown Not Working

Oct 14, 2010 at 4:23 PM

I'm using with Umbraco 4.5. Works well for the most part, but getting this error for drop down with SQL lookup:

No valid runtime detected

Shows an empty text box, too.

Coordinator
Oct 14, 2010 at 6:23 PM

Hi Robert,

No exactly sure how this happens. This error - is it an exception? If yes, can you post the stacktrace? Also what drop down control are you using exactly?

Btw. I monitor both our.umbraco and CodePlex, but I'll answer here, because it makes its easier to create a work item.

- Sune

Oct 14, 2010 at 7:49 PM

Sune,

I reverted to 1.1 (not Alpha) and it works now. However, I had to implement the True/False fix as outlined elsewhere here.

BTW, is there some reason the Umbraco User Control Wrapper type won't work? Tried that and it fails... Just show the Duo Select control for some reason. The control works in other documents.

 

Robert

Coordinator
Oct 14, 2010 at 8:08 PM

Okay, good that 1.1 solves it, even though it's not optimal. What version of ASP.NET are you using?

Sorry to say that I haven't tested it with the UserControlWrapper. I'll test it and get back to you, it should be possible :)

- Sune

Oct 14, 2010 at 8:24 PM

Cool, thanks! One other little thing: it would be helpful if you could just reference a connection string stored in the web.config rather than have the entire connection string in the DEWD config file.

But I gotta say, this is one awesome app and a real time saver!

Coordinator
Oct 14, 2010 at 8:33 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Coordinator
Oct 14, 2010 at 8:37 PM

Agree with your suggestion regarding connection strings - I think it would make sense to be able to use the ADO.NET provider model as well, so I'll look into that.

Glad you like it :)